Panels not following Daylight Savings Time

Incident Report for Brivo

Resolved

This incident has been resolved
Posted Mar 09, 2026 - 19:26 EDT

Monitoring

A fix has been implemented and we are monitoring the results
Posted Mar 09, 2026 - 17:05 EDT

Identified

We are aware that some panels are not following Daylight Savings Time. The issue has been identified, and a fix is being implemented.
Posted Mar 09, 2026 - 14:09 EDT
This incident affected: Panels (Brivo Panels).