Toll-free Phone Numbers Unavailable

Incident Report for Brivo

Resolved

All toll-free numbers have been restored and are once again available to customers and resellers. Thank you for your patience.
Posted Mar 03, 2026 - 17:22 EST

Investigating

We are currently experiencing issues with our toll-free numbers. Brivo Customer Care is still available through our interactive chat or by calling 855-500-0027.

We apologize for the inconvenience.
Posted Mar 03, 2026 - 14:39 EST